【備忘録】Eclipseの「PHP 言語ライブラリー」のバージョン変更方法

★環境
 Eclipse:Version: 2020-12 M1 (4.18.0 M1)

EclipseでPHPの開発をしてますが、phpファイルの中には正しい書き方なのにエラー表示されています。

これは、Eclipseの「PHP 言語ライブラリー」のバージョンが最新版でないため、その構文をエラーと判断してしまうからです。

Eclipseの「PHP 言語ライブラリー」

標準のままPHPプロジェクトを使用したら「PHP 5.6」となってました。

2021年8月時点では7.4が最新版ですので、このライブラリーのバージョンを変更します。

  1. 「プロジェクト」を右クリック
  2. 「プロパティ」を選択
  3. プロジェクトのプロジェクトの左メニューから「PHP」と「検証」を選択
  4. 「プロジェクト固有の設定を可能にする」にチェックを入れる
  5. 「バージョン」からPHPのバージョンを選択する
  6. 「適用して閉じる」を選択
よかったらシェアしてね!
目次
閉じる